范例目录

欢迎使用讯通天下短信接口(3.0)

欢迎使用讯通天下短信接口

本文档详细地描述了各种接口的使用方法，并且提供了各种语言的示例代码。

使用前请仔细阅读文档，并且参考示例代码。

如果您还有什么问题，请咨询我公司的技术支持人员。我们一定尽全力提供我们的支持。

HTTP

DLL

WebService

示例代码


范例目录

欢迎使用讯通天下短信接口(3.0)

  • 概述
  • 协议描述
  • 功能描述
  • 注意事项
  • 示例代码
  • 附件
    • 返回值代码表


概述

我公司短信服务提供了多种形式的接入接口.

本帮助文档描述其中的HTTP接口.

HTTP接口的主要特点是客户应用与短信服务器之间采用HTTP协议进行通讯。

每次客户做一次请求服务器做一次应答，如图:

本接口具有以下特性:

  • 支持的请求方式包括GET 和POST.
  • 接口负责对内容的分段.
  • 接口不负责签名和分段时候添加段落标示,由客户自己完成.
  • 本接口支持MD5加密策略,具体请参考相关文档.


协议描述

  • 目录
    • 发送短信
    • 接收短信
    • 获得客户的属性信息
    • 设置客户的属性信息
    • 扩展功能
  • 功能详细描述以及参数说明
    • 发送短信
      • 功能描述: 发送短信
      • 参数

        • 参数名称

        类型

        值

        备注

        Command

        String

        SendSMS

        命令字

        Username

        String[20]

        账号

        Password

        String[20]

        密码

        Mobiles

        String[4096]

        终端号码

        多个号码时使用半角逗号分隔，每次最多提交 300 个号码

        Msg

        String[300]

        信息内容

        内容请不要超过 300 个字， 300 个字内服务器负责自动分段。

        ExNo

        String[10]

        扩展号码

        可为空 , 为空时不做扩展 .

        ( 具体的扩展能力由服务器决定 )

        AtTime

        String[20]

        定时时间

        可为空 , 为空时立即发送

        小于当前时间的将被处理为立即发送

        超过当前时间 365 天的 将返回失败

        ExParam

        String[1024]

        扩展参数

        可为空 , 保留参数

      • 返回值
        返回值以XML描述,各个字段含义如下:

        参数名称

        类型

        值

        备注

        Result

        Integer

        结果代码

        ResultMsg

        String

        结果描述

        Balance

        Integer

        余额

        FailCount

        Integer

        失败号码数

        FailItems

        XML

        描述各个失败部分

        每一个失败描述为一个 Item

        FailItems 中 Item 项的描述

        Mobile

        String

        失败的号码信息

        对于重复号码错误 除返回号码以外 还在号码后面括号内返回这个号码在提交号码列表中的位置

        如 13788896321[32] 含义为 在号码列表中的第 32 个号码 13788896321 和前面的号码重复

        Reason

        integer

        失败的原因

        以代码形式描述，在结果代码表中有对应

    • 接收短信
      • 功能描述: 从服务器接收客户从手机回复的短信
      • 参数

        • 参数名称

        类型

        值

        备注

        参数名称

        类型

        值

        备注

        Command

        String

        RecvSMS

        命令字

        Username

        String[20]

        账号

        Password

        String[20]

        密码

        FromID

        String[20]

        接收位置

        参数为空时 从第一个未阅读信息接收

        参数为“ 0 ”时 从系统保存的第一个信息开始接收

        ExParam

        String[1024]

        扩展参数

        可为空 , 保留参数

      • 返回值
        返回值以XML描述,各个字段含义如下：

        参数名称

        类型

        值

        备注

        Result

        Integer

        结果代码

        ResultMsg

        String

        结果描述

        MsgCount

        Integer

        接收到的信息条数

        MsgItems

        XML

        描述各个信息项目

        每一个信息项目描述为一个 Item

        Items 中 Item 信息项的结构描述

        ID

        Integer

        信息 ID

        用于逻辑处理，如下次从此 ID 开始接受

        From

        String

        信息来源

        终端的号码 如手机号码

        To

        String

        信息目的

        Msg

        String

        信息内容

        RecvTime

        String

        接收时间

        格式如 2008-05-01 12:10:32

    • 获得客户的属性信息
      • 功能描述: 获得账号对应的客户的某些属性信息
      • 参数

        • 参数名称

        类型

        值

        备注

        参数名称

        类型

        值

        备注

        Command

        String

        GetProperty

        命令字

        Username

        String[20]

        账号

        Password

        String[20]

        密码

      • 返回值
        返回值以XML描述,各个字段含义如下：

        参数名称

        类型

        值

        备注

        Result

        String

        结果代码

        ResultMsg

        String

        结果描述

        UserID

        String

        客户 ID

        Balance

        Integer

        余额

        ClientText

        String

        客户提示信息

        Others

        String

        保留的返回参数

        除已描述的参数外还保留有其他参数的返回的可能。

    • 设置客户的属性信息
      • 功能描述:设置账号对应的客户的某些属性信息
      • 参数

        • 参数名称

        类型

        值

        备注

        Command

        String

        SetProperty

        定值字符串

        Username

        String[20]

        账号

        Password

        String[20]

        密码

        PropertyName

        String[1024]

        属性名称

        PropertyValue

        String[1024]

        属性值

      • 返回值
        返回值以XML描述,各个字段含义如下：

        参数名称

        类型

        值

        备注

        Result

        String

        结果代码

        ResultMsg

        String

        结果描述

    • 扩展功能
      • 功能描述: 扩展功能。支持某些功能的实现,具体请参照功能实现文档.
      • 参数

        • 参数名称

        类型

        值

        备注

        Command

        String

        ExCommand

        定值字符串

        Username

        String[20]

        账号

        Password

        String[20]

        密码

        Param

        String[1024]

        参数

      • 返回值
        返回值以XML描述,各个字段含义如下：

        参数名称

        类型

        值

        备注

        Result

        String

        结果代码

        ResultMsg

        String

        结果描述


功能描述

  • 发送短信
  • 接收短信
  • 获得客户属性
  • 设置密码
  • 内容检查

  • 发送短信

功能描述：群发短信。

方法：参照“协议描述/发送短信” 构造URL,然后对该URL进行HTTP请求,返回的内容即为结果。返回的结果含义请参照协议描述。

例：

请求：

http://vip.mston.com/SMSAPI/SMSSV.aspx?Command=SendSMS&Username=admin&Password=admin&Mobiles=13788896321&Msg=%b2%e2%ca%d4&AtTime=&ExNo=

返回：

<?xml version="1.0" encoding="gb2312"?>
<XMLResult>
<Result>0</Result>
<ResultMsg>成功</ResultMsg>
<Balance>1206</Balance>
<FailCount>0</FailCount>
<FailItems>
</FailItems>
</XMLResult>

  • 接收短信

功能描述：接收手机发送上来的信息(MO)。

方法：参照“协议描述/ 接收短信” 构造URL,然后对该URL进行HTTP请求,返回的内容即为结果。返回的结果含义请参照协议描述。

  • 获得客户属性

功能描述：获得客户属性 包括剩余的短信条数和各个类型号码支持的字数等。

方法：参照“协议描述/获得客户属性” 构造URL,然后对该URL进行HTTP请求,返回的内容即为结果。返回的结果含义请参照协议描述。

备注：

  • 设置密码

功能描述：重新设置密码。

方法：参照“协议描述/设置客户的属性信息” 构造URL,然后对该URL进行HTTP请求,返回的内容即为结果。返回的结果含义请参照协议描述。

参数PropertyName为字符串Password.

参数PropertyValue为您需要设置的新密码.

  • 内容检查

功能描述：检查内容中是否包含有禁止发送的词汇。

方法：参照“协议描述/扩展功能” 构造URL,然后对该URL进行HTTP请求,返回的内容即为结果。返回的结果含义请参照协议描述。

参数Param为字符串"CheckMsg:"+需要检查的内容. 如 "CheckMsg:测试信息"


无标题文档

注意事项

1 初次使用过程中请详细阅读 《协议描述》《功能描述》等重要文档,然后运行示例检查是否可以工作正常。

2 我们提供了各种语言的示例,每种示例中均有封装好的类或者函数,建议在开发过程中参考示例。

3 在调用程序中,请做好日至记录工作,尤其是异常情况下的日志纪录,以方便日后查找原因。


无标题文档

结果代码表

0：成功

-1100：验证失败 账号或者密码不正确.
-1101：账号不存在
-1102：密码错误
-1103：错误的输入参数
-1104：账号被暂停
-1105：账号没有使用接口的权限
-1106：当前IP不允许访问

-1201：发送 号码参数错误
-1202：发送 内容参数错误
-1203：发送 扩展号码错误
-1204：发送 扩展参数错误
-1205：发送 内容包含敏感关键词
-1206：发送 费用不足
-1207：发送 号码被屏蔽
-1208：发送 不是有效的号码
-1209：发送 该号码重复出现
-1210：发送 短信类型无效

-1301：接收 位置参数错误
-1302：接收 与上一次接收时间间隔过短 请稍后再接收
-1303：接收 服务器忙 请稍后再试

-1501：设置属性 错误的属性名称
-1502：设置属性 错误的属性值
-1503：设置属性 不支持操作
-1504：设置密码失败。请确定原密码和账号正确。

-1601：获得账号属性时错误，系统错误。

-1701：扩展功能接口错误。不支持的操作。

-1000：短信接口服务内部错误，系统错误。
-1011：获得账号信息时错误，系统错误。


范例目录

欢迎使用讯通天下短信接口(3.0)

  • 概述
  • 协议文档
  • 功能描述
  • 注意事项
  • 示例代码
  • 附件
    • 返回值代码表


概述

我公司短信服务提供了多种形式的接入接口.

本文档描述其中的DLL接口.

DLL接口的客户应用与短信服务器之间采用TCP/IP协议进行通讯.客户端与服务器保持长连接.

本接口具有以下特性:

  • 直接通过TCP/IP进行网络通讯.
  • 安全可靠,高性能。适合高质量的群发需求.
  • 接口可以负责分段、签名等处理.

使用须知:

  • 该接口使用TCP/IP进行网络通讯,服务器端口固定为8000或7000.客户端端口为随机.请保证接口所需网络支持的畅通.


协议描述

  • 目录
    • 登录
    • 登出
    • 发送短信
    • 接收短信
    • 获得客户的属性信息
    • 设置客户的属性信息
    • 扩展功能
  • 功能详细描述以及参数说明
    • 登录
      • 功能描述:
        与短信服务器建立连接,并登录.
      • 函数原形:
        Function Login(Host,Port,Username,Password:PChar):Integer; stdcall;
      • 参数说明:

        • 参数名称

        类型

        值

        备注

        Host

        PChar

        服务器主机地址

        Port

        PChar

        服务器主机端口号

        Username

        PChar

        账号

        Password

        PChar

        密码

      • 返回值:
        返回值为Integer类型.
        登录成功时,返回值为与服务器的连接句柄.
        登录失败时,返回值为失败代码.请参照代码表确定失败原因
    • 登出
      • 功能描述:
        注销登录状态并与短信服务器断开连接.
      • 函数原形:
        Function Logout(ClientID: Integer): Integer; stdcall;
      • 参数说明:

        参数名称

        类型

        值

        备注

        ClientID

        PChar

        与服务器的连接句柄

        该句柄由登录函数成功后返回.
      • 返回值:
        返回值为Integer类型.
        成功时,返回值0.
        失败时,返回值为失败代码.请参照代码表确定失败原因.
    • 发送短信
      • 功能描述:
        发送短信.
      • 函数原形:
        Function Send(ClientID: Integer; Mobiles,Msg,ExNum,AtTime,ExParam:PChar; ResultValue:Pchar; var ResultSize:integer): integer; stdcall;
      • 参数说明:

        参数名称

        类型

        值

        备注

        ClientID

        PChar

        与服务器的连接句柄

        该句柄由登录函数成功后返回.

        Mobiles

        PChar

        目标号码

        多个号码时号码之间用半角逗号分隔

        Msg

        PChar

        信息内容

        ExNum

        PChar

        扩展特服号码

        AtTime

        PChar

        定时时间

        为空时立即发送.

        ExParam

        PChar

        扩展参数

        扩展参数,无特殊说明下为空即可.

        ResultValue

        PChar

        发送结果

        请参照下面的详细描述.

        ResultSize

        PChar

        发送结果长度

      • 发送结果 ResultValue 说明:
        返回参数,请事先分配足够的存储空间.
        • 该返回参数以XML形式描述发送调用的具体结果,如发送后的余额,发送失败的号码以及失败原因等.

        参数名称

        类型

        值

        备注

        ResultMsg

        String

        结果描述

        Balance

        Integer

        余额

        FailCount

        Integer

        失败号码数

        FailItems

        XML

        描述各个失败部分

        每一个失败描述为一个 Item

        FailItems 中 Item 项的描述

        Mobile

        String

        失败的号码信息

        对于重复号码错误 除返回号码以外 还在号码后面括号内返回这个号码在提交号码列表中的位置

        如 13788896321[32] 含义为 在号码列表中的第 32 个号码 13788896321 和前面的号码重复

        Reason

        integer

        失败的原因

        以代码形式描述，在结果代码表中有对应

      • 返回值:
        返回值为Integer类型.描述本次调用的返回.
        成功时,返回值0.
        失败时,返回值为失败代码.请参照代码表确定失败原因.
    • 接收短信
      • 功能描述:
        接收短信.
      • 函数原形:
        Function Recv(ClientID: Integer;FromID:integer; ResultValue:Pchar; var ResultSize:integer): integer; stdcall;
      • 参数说明:

        • 参数名称

        类型

        值

        备注

        ClientID

        PChar

        与服务器的连接句柄

        该句柄由登录函数成功后返回.

        FromID

        PChar

        开始接收位置

        参数为空时 从第一个未阅读信息接收

        参数为“ 0 ”时 从系统保存的第一个信息开始接收

        ResultValue

        PChar

        接收结果

        请参照下面的详细描述.

        ResultSize

        PChar

        结果长度

      • 开始接收位置 FromID 说明

      每条上行信息对应一个为的ID.

      当FromID=-1时,接收将从第一个未读取过的信息开始读取,并且只读取未读取过的信息.

      当FromID>=0时候,接收将从FromID参数指定的位置开始(不包括)读取,不计较读取标志.

      • 接收结果 ResultValue 描述:

        返回参数,请事先分配足够的存储空间.

        该参数以XML形式描述接收信息结果.

        • 参数名称

        类型

        值

        备注

        ResultMsg

        String

        结果描述

        MsgCount

        Integer

        接收到的信息条数

        MsgItems

        XML

        描述各个信息项目

        每一个信息项目描述为一个 Item

        MsgItems 中 Item 信息项的结构描述

        ID

        Integer

        信息 ID

        用于逻辑处理，如下次从此 ID 开始接受

        From

        String

        信息来源

        终端的号码 如手机号码

        To

        String

        信息目的

        Msg

        String

        信息内容

        RecvTime

        String

        接收时间

        格式如 2008-05-01 12:10:32

      • 返回值:
        返回值为Integer类型.描述本次调用的返回.
        成功时,返回值0.
        失败时,返回值为失败代码.请参照代码表确定失败原因.
    • 获得客户的属性信息
      • 功能描述:
        获得账号对应的客户的某些属性信息
      • 函数原形:
        Function GetProperty(ClientID: Integer; ResultValue:Pchar; var ResultSize:integer): integer; stdcall;
      • 参数说明:

        • 参数名称

        类型

        值

        备注

        ClientID

        PChar

        与服务器的连接句柄

        该句柄由登录函数成功后返回.

        ResultValue

        PChar

        执行结果

        请参照下面的详细描述.

        ResultSize

        PChar

        结果长度

      • 执行结果 ResultValue 描述:
        返回值以XML描述,各个字段含义如下：

        参数名称

        类型

        值

        备注

        ResultMsg

        String

        结果描述

        UserID

        String

        客户 ID

        Balance

        Integer

        余额

        ClientText

        String

        客户提示信息

        Others

        String

        保留的返回参数

        除已描述的参数外还保留有其他参数的返回的可能。
      • 返回值:
        返回值为Integer类型.描述本次调用的返回.
        成功时,返回值0.
        失败时,返回值为失败代码.请参照代码表确定失败原因.
    • 设置客户的属性信息
      • 功能描述:
        设置账号对应的客户的某些属性信息
      • 函数原形:
        Function SetProperty(ClientID: Integer;PropertyName,PropertyValue:PChar; ResultValue:Pchar; var ResultSize:integer): integer; stdcall;
      • 参数说明:

        • 参数名称

        类型

        值

        备注

        ClientID

        PChar

        与服务器的连接句柄

        该句柄由登录函数成功后返回.

        PropertyName

        PChar

        属性名称

        PropertyValue

        PChar

        属性值

        ResultValue

        PChar

        执行结果

        请参照下面的详细描述.

        ResultSize

        PChar

        结果长度

      • 结果:
        返回值以XML描述,各个字段含义如下：

        • 参数名称

        类型

        值

        备注

        ResultMsg

        String

        结果描述

      • 返回值:
        返回值为Integer类型.描述本次调用的返回.
        成功时,返回值0.
        失败时,返回值为失败代码.请参照代码表确定失败原因.
    • 扩展功能
      • 功能描述:
        扩展功能,支持某些功能的实现,具体请参照功能实现文档.
      • 函数原形:
        Function ExCommand(ClientID: Integer;Param:PChar; ResultValue:Pchar; var ResultSize:integer): integer; stdcall
      • 参数说明:

        • 参数名称

        类型

        值

        备注

        ClientID

        PChar

        与服务器的连接句柄

        该句柄由登录函数成功后返回.

        Username

        String[20]

        账号

        Password

        String[20]

        密码

        Param

        String[1024]

        参数

      • 结果:
        返回值以XML描述,各个字段含义如下：

        • 参数名称

        类型

        值

        备注

        ResultMsg

        String

        结果描述

        ResultValue

        String

        返回的结果值

        不同的功能返回结果值不同,具体请参照相应功能的说明.

      • 返回值:
        返回值为Integer类型.描述本次调用的返回.
        成功时,返回值0.
        失败时,返回值为失败代码.请参照代码表确定失败原因.


功能描述

  • 登录
  • 登出
  • 发送短信
  • 接收短信
  • 获得客户属性
  • 设置密码
  • 保持连接
  • 内容检查

  • 登录

功能描述：与服务器建立连接，并且验证账号密码等。此过程为以下所有功能的前提。

方法：通过执行 Login 进行登录,详细信息请参照“协议描述/登录”。

备注：

1 如果不能登录，请检查网络情况。

2 我公司提供多台服务器同时服务，请在连接某服务器不成功时尝试连接其他服务器。

  • 登出

功能描述：注销登入状态, 与服务器断开连接,同时释放一部分资源。

方法：执行 Logout ,详细信息请参照“协议描述/登出”。

备注：

1 请在不再使用网络或者程序退出的时候执行该方法,有利于资源的释放。

  • 发送短信

功能描述：群发短信。

方法：执行 Send ,详细信息请参照“协议描述/发送短信”。

备注：

1 输入和返回参数 请参照文档.

2 该方法必须在成功登录后进行。

3 请详细的记录异常情况下的信息，以便在出现问题的时候做相应的分析。

  • 接收短信

功能描述：接收手机发送上来的信息(MO)。

方法：执行 Recv ,详细信息请参照“协议描述/接收短信”。

备注：

1 请参照协议描述文档理解FromID参数的含义.

  • 获得客户属性

功能描述：获得客户属性 包括剩余的短信条数和各个类型号码支持的字数等。

方法：执行 GetProperty ,详细信息请参照“协议描述/获得客户的属性信息”。

备注：

  • 设置密码

功能描述：重新设置密码。

方法：执行 SetProperty ,详细信息请参照“协议描述/设置客户的属性信息”。

参数PropertyName为字符串Password.

参数PropertyValue为您需要设置的新密码.

  • 保持连接

功能描述：重新设置密码。

方法：执行 ExCommand ,详细信息请参照“协议描述/扩展功能”。

参数Param为字符串KeepAlive.

  • 内容检查

功能描述：检查内容中是否包含有禁止发送的词汇。

方法：执行 ExCommand ,详细信息请参照“协议描述/扩展功能”。

参数Param为字符串"CheckMsg:"+需要检查的内容. 如 "CheckMsg:测试信息"


无标题文档

注意事项

1 初次使用过程中请详细阅读 《协议描述》《功能描述》等重要文档,然后运行示例检查是否可以工作正常。

2 我们提供了各种语言的示例,每种示例中均有封装好的类或者函数,建议在开发过程中参考示例。

3 在调用程序中,请做好日至记录工作,尤其是异常情况下的日志纪录,以方便日后查找原因。

4 请特别注意,函数调用中有返回参数的, 由调用程序事先分配好内存空间,并在使用后释放.DLL内部不做输出参数内存的分配和释放工作. 此问题处理不好可能导致内存泄漏.

如我们的几个函数中 ResultValue 用于返回结果描述的字符串,一定要实现分配好足够的内存.

ResultSize 返回了返回内容的有效长度.


结果代码表

0：成功

-1100：验证失败 账号或者密码不正确.
-1101：账号不存在
-1102：密码错误
-1103：错误的输入参数
-1104：账号被暂停
-1105：账号没有使用接口的权限
-1106：当前IP不允许访问

-1201：发送 号码参数错误
-1202：发送 内容参数错误
-1203：发送 扩展号码错误
-1204：发送 扩展参数错误
-1205：发送 内容包含敏感关键词
-1206：发送 费用不足
-1207：发送 号码被屏蔽
-1208：发送 不是有效的号码
-1209：发送 该号码重复出现
-1210：发送 短信类型无效

-1301：接收 位置参数错误
-1302：接收 与上一次接收时间间隔过短 请稍后再接收
-1303：接收 服务器忙 请稍后再试

-1501：设置属性 错误的属性名称
-1502：设置属性 错误的属性值
-1503：设置属性 不支持操作
-1504：设置密码失败。请确定原密码和账号正确。

-1601：获得账号属性时错误，系统错误。

-1701：扩展功能接口错误。不支持的操作。

-1000：短信接口服务内部错误，系统错误。
-1011：获得账号信息时错误，系统错误。
-1012：无效的句柄
-1900：服务器未知错误
-1901：客户端未知错误
-10054 ：网络错误 服务器无响应
-10061 ：网络错误 服务器无响应

注： 标注有“系统错误”的返回为我公司服务程序内部错误，遇到这些错误时候 请尝试稍后再次提交，如再次提交仍不成功 请联系我们。

发送接口可能的返回值：
0
-1100 -1101 -1102 -1103 -1104 -1105 -1106
-1201 -1202 -1203 -1204 -1205 -1206 -1210
-1000 -1011 -1012 -1900 -1901 -10054 -10061

以上结果中
除了0和 -1206 情况以外
可以认为提交的信息全部失败
返回 0 或者 -1206情况
需要根据失败返回数据处理失败号码
返回的失败号码以外的均为成功

返回 -10054 ，-10061? 情况下 请重新做登录操作后进行重发。

客户端请对非0返回值情况的 提交号码 信息内容 时间等 作详细日至 ，以便备查 。

对于发送
具体失败原因 可能值
-1207 -1208 -1209
以上错误返回时 对发送是否成功的判断


范例目录

欢迎使用讯通天下短信接口(3.0)

服务地址

http://vip.mston.com/smsapi/smsws.asmx

服务说明地址

http://vip.mston.com/smsapi/smsws.asmx?WSDL

功能说明:

SendSMS 发送短信

参数

Username：账号

Password：密码

Mobiles：号码，多个号码时 使用逗号分隔

Msg：信息内容

ExNo：扩展号码,可为空

AtTime：定时时间,为空时候立即发送

ExParam：扩展参数, 为空即可。

返回值： 请参照 协议描述

RecvSMS 接收短信

参数

Username：账号

Password：密码

FromID：接收位置

更多信息请参照 协议描述

GetProperty获得属性

参数

Username：账号

Password：密码

更多信息请参照 协议描述

SetProperty 设置属性

参数

Username：账号

Password：密码

PropertyName：属性名称

PropertyValue：属性值

更多信息请参照 协议描述

ExCommand扩展命令

参数

Username：账号

Password：密码

Param：命令参数

更多信息请参照 协议描述

设置密码：

使用SetProperty 方法

PropertyName参数填写Password

PropertyValue参数填写需要设置的新密码

更多信息请参照 协议描述

内容检查

使用ExCommand方法

Param参数填写“CheckMsg:”+需要检查的内容

更多信息请参照 协议描述


目录

讯通天下接口示例目录

全部示例代码压缩包下载

  • C# 示例
    • HTTP
      • CSharpWeb中使用HTTP30接口 完整工程
      • CSharpWinform中使用HTTP30接口 完整工程
      • SMSWorker.cs 对HTTP接口的封装 以上两个示例都使用该类实现
    • DLL
      • 完整工程
      • smsDll.cs 封装了对接口Dll的调用
      • smsWorker.cs 对各个功能进行了封装 可以直接用复制并用在您的C#中
  • Delphi
    • DLL
      • 完整工程
      • USmsNet.pas 对接口封装后的类 可直接使用。
    • HTTP
      • 完整工程
      • HttpSms.pas 对接口封装后的类 可直接使用。
  • C++
    • HTTP
      • 完整工程
      • HttpSms.h 对接口封装后的类 可直接使用。
    • DLL
      • 完整工程
      • SmsSender.h 对接口封装后的类 可直接使用。